sábado, enero 15, 2011

Instalación de VMware Workstation en Archlinux





Lo primero que necesitáis es una versión de VMware para Linux, es decir, con extensión .bundle. Podéis descargarla tanto de la página oficial de VMware (os pedirá registraros) o por otros modos. Sólo fijaros en que sea una versión nueva (VMware 7.x.x) y que su extensión sea .bundle.




Una vez descargada, navegar mediante terminal a la carpeta donde la habéis descargado. En mi caso, en Descargas.


cd /Descargas


Si el archivo en sí se descargara en una carpeta, tenéis que ir entrando en todos los directorios hasta la última carpeta. Una vez dentro de la última carpeta, necesitamos realizar una serie de pasos:


mkdir -p /etc/rc.d/vmware.d/{rc{0..6},init}.d
chmod +x VMware_como_se_llame_vuestro_archivo.bundle
sudo ./VMware_como_se_llame_vuestro_archivo.bundle --console --custom


Fijaros en el último comando y que no se os olvide añadir al final, --console y --custom. Se os iniciará la instalación de VMware desde terminal. Aceptad el EULA, he id aceptando los sucesivos puntos, pero fijaros, porque algunos de ellos tenemos que editarlos. Cuando lleguemos a la opción System service runlevels hay que poner:


/etc/rc.d/vmware.d


Seguid aceptando las demás opciones. Tendría que terminar toda la instalación sin ningún problema. Ahora, tendríamos que instalar los módulos necesarios para que VMware funcione. Para ello, haced lo siguiente:


sudo ln -s /bin/lsmod /sbin/lsmod


El siguiente paso va condicionado con el kernel que tengáis. Averigüemos primero que kernel tenemos:


uname -r


Este comando os devolverá que versión de kernel actualmente usáis. En mi caso, estoy utilizando la versión 2.6.36-ARCH. Para hacer funcionar VMware en estos kernel, es necesario la aplicación de un parche. Si consultáis la guía oficial de instalación de VMware en la ArchWiki, veréis que están puestos los parches para el kernel 2.6.36 y para el 2.6.35. 


En mi caso, por más que he intentando aplicar el parche para mi kernel (el 2.6.36) no hay forma. Así que probé instalando el parche para el kernel 2.6.35 ¡y funciona! ¡Sin rechistar! Os pongo los dos parches que están puestos en la Wiki Oficial y vosotros elegís. Ya sabéis, si no os funciona el parche para el kernel 2.6.36, probad con el parche para el 2.6.35 sin miedo. 


Parche para el kernel 2.6.36:


cd /tmp
wget  http://files.archlinux.org.il/vmmon_fix_2.6.36.sh 
chmod +x vmmon_fix_2.6.36.sh
sudo ./vmmon_fix_2.6.36.sh


Parche para el kernel 2.6.35:


 cd /tmp
wget http://www.sputnick-area.net/scripts/vmware7.1.1-patch-kernel-2.6.35.bash
chmod +x vmware7.1.1-patch-kernel-2.6.35.bash
sudo ./vmware7.1.1-patch-kernel-2.6.35.bash


Ahora ya podríais instalar los modulos. Podéis hacerlo uno a uno o mediante el comando:


vmware-modconfig --console --install-all


De manera opcional podéis añadir VMware a Daemons, para que se inicien estos servicios al inicio. 


sudo nano /etc/rc.conf
Daemons (.......vmware....)


Ya podéis iniciar VMware Workstation desde el Menú o desde terminal. Tendría que configurarse e iniciarse normalmente. Espero que nos hayáis hecho mucho lío y que si tenéis el mismo problema con el kernel 2.6.36, os sirva el truquillo de utilizar el otro parche. Por supuesto, referencias todas a la Wiki oficial de VMware en Arch, ya que simplemente, mi post es una traducción ( más o menos afortunada) al español, intentando explicarlo un poco más claro, así como el tema del parche del kernel.


Si algo no os cuadra o queréis consultar la guía oficial:


https://wiki.archlinux.org/index.php/VMware


Saludos!!! ^^ 




sábado, enero 08, 2011

aTunes: el "iTunes" multiplataforma

aTunes es un completo reproductor de música multiplataforma, ya que está programado en Java. Admite los formatos de música más conocidos (ogg, mp3, wma, flac,mp4, wav..). Además, lo acompaña con un editor de etiquetas muy sencillo y útil, así como radios en streaming, cargador de carátulas, la posibilidad de crear Cd's de audio, etc..




El compararlo con "iTunes" viene al caso, no de su parecido estético, donde es bastante basto, pero sí en cuanto a su funcionalidad y usabilidad para utilizar un reproductor de Apple. Permite editar las etiquetas tanto del "Repositorio" (carpeta de tu ordenador o carpetas donde alojas tu música) como del iPod, modificandolas al momento sin cuelgues del programa ni problemas. El pase de canciones de un dispositivo a otro también se realiza de la manera más sencilla. Permite tener varios reproductores portables enchufados, mediante un gestor de dispositivos intuitivo, con las opciones de Conectar, Desconectar y Actualizar.


En cuanto a las radios en Streaming, vienen predefinidas una gran lista. Si no te gustan o prefieres añadir las tuyas propias, en propiedades basta con marcar la opción de "No mostrar radios predefinidas", por lo que sólo saldrían aquellas radios añadidas por el usuario. También permite la utilización de Podcasts, añadiendolos mediante URL.


Permite la integración con Last FM, que da información del artista, canciones del mismo Album de la que se está reproduciendo, videos en Youtube de la canción o relacionados, etc.. En cuanto a aspecto visual, es bastante simple, pero para estar sobre Java, funciona rápido y sin cuelgues.








En resumen, aTunes se ofrece como una buena alternativa a iTunes, ya que hace de la sincronización de iPods un juego de niños.


Página oficial:


http://www.atunes.org/


Podéis instalarlo desde su página web o bien, desde los repositorios de AUR:


yaourt -S atunes


Recordad que necesitáis tener instalado Java para que funcione el reproductor. Saludos!! ^^




Petición a SE para que actualice los Xperia x10 a Froyo

Estamos hasta las narices. De verdad. Tenemos uno de los mejores móviles en cuanto a hardware del mercado, al que se puede exprimir una barbaridad obteniendo de lo mejorcito en cuanto a resultados, pero los de Sony Ericsson se ve que nos odian.


Y digo odiar, porque esto ya no es normal. Actualizaciones que tardan una eternidad, poco soporte, versiones de Android que otros móviles dejaron atrás hace un año y un largo etcétera que hará que muchas personas se lo piensen antes de comprarse este genial bichin. El movil merece la pena, pero sin unas actualizaciones con que podamos ponerlos a la última (como el puñetero flash, que creo que no pedimos tanto) se queda bastante desfasado, teniendo que aguantar que otros dispositivos móviles más normalitos, nos peguen una pasada en el ranking de dispositivos con Android. 


Y no somos pocos, como bien se puede ver en esta página de firmas, para pedir a SE que nos actualice de una vez a Froyo (a poder ser, con Multitouch y Flash). Si queréis uniros, o tenéis otros dispositivos móviles pero os sentís generosos con los que sufrimos, firmad aquí:


http://www.petitiononline.com/froyo/petition.html


Direis: no sirve para nada. No, no es verdad. Lo que no sirve para nada es que nos quedemos cruzados de brazos mientras vemos como las posibilidades de nuestros dispositivos disminuyen con cada día que pasa. Y al menos a mí, me tiene ganada este móvil y me niego a pensar en reemplazarlo por otro, con características peores sólo porque tengan Android actualizado.


Saludos!! ^^


martes, enero 04, 2011

Ex Falso, complemento de edición de etiquetas para Exaile


Un excelente complemento de Exaile para mantener nuestra colección al día con todas sus etiquetas bien puestas es Exfalso. Es sencillo, rápido, muy cómodo e intuitivo. Sólo basta con decirle la carpeta donde están las canciones e ir uno por uno, artista por artista, editando sus etiquetas. Ofrece múltiples etiquetas muy útiles, así como la opción de ir ordenandolas por diferentes criterios.


Lo mejor de todo es que al terminar, te vas a Exaile, reescaneas la colección y ¡voilá! todas las etiquetas bien puestas, sin cuelgues en la reproducción y en un segundo (bueno, supongo que el tiempo varia dependiendo del tamaño de tu colección, pero es bastante rápido).


Si al intentar activar os dice error, fijaros en el archivo que os dice que os falta. Instalarlo por terminal y sin problemas, ya podréis activarlo. El programa aparecerá en vuestro menú, en Sonido y vídeo.


Saludos!! ^^




Exaile, el Amarok de Gnome



Salvando las distancias con Amarok el cual es uno de los mejores reproductores de música de GNU/Linux, Exaile es una buena alternativa si por lo que sea, Amarok no nos termina de convencer (como es mi caso).

Buscando una alternativa a Amarok, recalé en Exaile. En cuanto a aspecto visual, esta un poco menos cuidado que Amarok, aunque en cuestión de gustos no hay nada escrito.

Con respecto a la funcionalidad, para mi gusto es bastante rápido y sencillo, sin echar en falta ninguna de las opciones de Amarok (al menos, en el uso que le doy yo al reproductor).

Lee caratulas, soporta OSD para las notificaciones, tiene opción para leer las letras de las canciones, así como de un Karaoke (elimina las voces del audio para que cantes tú xD), permite el uso de complementos, como por ejemplo, para utilizar el iPod. También incluye shoucast de radio, tanto de la lista, como las que tú quieras guardar.



La verdad es que es bastante completo y al menos, en mi ordenador, va muy rápido, sin cuelgues y con una buena calidad de sonido. De ahí que por ahora, sea mi reproductor de música por defecto. Si queréis probarlo:
sudo pacman -S exaile
Al activar algunos complementos os puede dar error, indicandoos los paquetes necesarios para su instalación. Basta con instalarlos por terminal y sin problemas. No hace falta reiniciar el programa para que ya funcionen. Para hacer funcionar las teclas multimedia de Gnome, activad el complemento llamado "Teclas multimedia de Gnome". Funcionan de maravilla.

Saludos!! ^^


Thunderbird en español





Si habeís instalado Thunderbird a través de pacman, os habreís dado cuenta de que os instala una versión en inglés. Para colocarlo en español:

http://releases.mozilla.org/pub/mozilla.org/thunderbird/releases/3.1.7/linux-i686/xpi/ 


Descargaros el idioma que querais ( en el caso de España, el idioma es el es_Es) Os descargais el xpi. Id en Thunderbird a la pestaña Tools -> Addons. En Get Addons, dadle al botón de Install, buscais el .xpi que os habeis descargado. Al instalarse, dadle a reiniciar y ya tendriais el Thunderbird en español.


Saludos!! ^^




 
Google+